Home » How To Play Diablo 1 on iPad in 3 easy steps [Universal Control or Keyboard+Mouse]

18 thoughts on “How To Play Diablo 1 on iPad in 3 easy steps [Universal Control or Keyboard+Mouse]

  1. This is freakin awesome! Totally works. However, sound doesn’t seem to work on my iPad (but it does work in my browser on my Mac). Is there something I need to do to get sound working? Problem occurs on both safari and chrome.

    1. Interesting, sound is working fine on my compiled build (method 2 that requires a developer account). Let me investigate for a bit and I’ll update the article if I find a solution.

      I remember sound working fine on my Air 4 the first time I tried it so it could be a recent iPad OS update? What OS version are you running?

      1. Nope, not in silent mode. I’m running 15.4.1 on a first edition iPad Pro. Just doing solution 1. I actually tried solution 2, but npm install threw tons of errors (I’m also a web dev). Didn’t look into what they were regarding, but I think one of the first was about node-sass. I was too excited to try to play, so I just abandoned that solution and went to the first one.
        Thanks for the quick response btw!

        1. Alright, all my iPads are on iPadOS 16 Beta. Going to downgrade the AIR and see if it’s a 15.x issue (though I had it running with sound on 15).

        2. Ok, I could have sworn audio worked on my Mac as well, but it’s not, at least not on Safari. It does on Chrome though, but Chrome’s performance with the game is horrid – there’s visual “tearing” in the background as I walk my character around. I am on an older Mac though – 2013 Macbook Pro running Catalina.

          1. Check firefox for Mac, I am successfully running it on Firefox on my 2014 dualcore MBPro (mid-2014). I just tested it on my Air 4 with iPadOS 15.5 and sound is working in safari with the first method.

            Chrome is a beast and a hog of resources on any device tbh.

            Not sure I can download iPadOS 15.4.1 anymore to try and test on that one. Going to try and check my GF’s normal iPad when she gets home, I know she rarely updates 😅

          2. I tried updating my iPad to 15.5, but still no sound 🙁
            I also tried FF on my Mac, but I get this error after selecting the MPQ file:
            ReferenceError: FileReader is not defined

          3. And if I try the shareware version on FF, I get this error instead:
            _e.includes is not a function

          4. Oh, and I also tried running the shareware version on Safari on my work mac (a 2021 MacBook Pro – M1 Max – running Monterey), and no sound there either (but Chrome again does have sound, and performance there is fine). Also tried FF there, and it DOES work there – no errors, sound is fine.

          5. So this is a really weird situation I guess. I gotta check the last github build, maybe the dev added something new that isn’t supported across all devices and browsers? Like a new sound format.

            I think I wrote this article in february so it’s a few months old. Worst comes to worst, I’ll try and get some time next weekend and do a new web build that I know works and host it somewhere.

            I know I was definetly able to play the full version without issues…

          6. So I tried Safari Tech Preview on my work MacBook, and sound does work there. So presumably they broke something in the latest Safari (which is confusingly enough versioned 15.5, same as latest version of iOS).

          7. This is ending up to be a fun exploration session @Dave where we learn more about the underlying system shared across MacOS and iOS/iPadOS.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.